This project is read-only.

js32.dll not found?

Topics: Developer Forum, User Forum
Jul 24, 2008 at 5:44 PM
Hi,

As soon as I call JS.Init, I get an DllNotFoundException (js32.dll). I tried putting js32.dll in my debug/release/system32 folder, but it didn't work.

Unable to load DLL 'js32.dll': The specified module could not be found. (Exception from HRESULT: 0x8007007E)

Any idea what I'm doing wrong here?

-Rynus_Rein
Jul 24, 2008 at 11:04 PM
already found it out: my application was missing msvc90.dll :-/
Seems  js32.dll is causing it, I fixed it by dynamically creating a reference to it in my manifest at build time :/
Feb 11, 2009 at 3:15 AM
Can you provide step by step directions please.
Apr 22, 2009 at 3:51 PM
I have a similar problem :

Unhandled Exception: System.DllNotFoundException: Unable to load DLL 'js32.dll':
 This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem. (Exception from HRESULT: 0x800736B1)
   at SpiderMonkey.JS.JS_Init(UInt32 maxbytes)
   at smnettest.Program.Main(String[] args)

Any idea ?
I use the beta 0.1.5.

Tkanos
Apr 22, 2009 at 3:59 PM
Edited Apr 22, 2009 at 4:00 PM
Maybe you're missing DLL dependencies. Try running DependencyWalker on it.
You you have a .manifest for it, if you haven't try generating one.

For more information, see this topic:
http://social.msdn.microsoft.com/Forums/en-US/vcgeneral/thread/36971526-95f3-4a9f-a601-1843c86332c1
Apr 23, 2009 at 7:55 AM
Thanks,

i'll try that.